A8a976a326bec5a34f35404dcb0d1fa6?s=64 spree

spree_social

19 2 0

Building block for spree social networking features (provides authentication and account linkage)

Dependencies

Package Locked Requirement Latest Status Changelog
Gems oa-core >= 0 0.3.2

oa-core

Core strategies for OmniAuth.

This dependency is up-to-date. Congrats and keep going!

Gems omniauth >= 0 1.2.1

omniauth

A generalized Rack framework for multiple-provider authentication.

This dependency is up-to-date. Congrats and keep going!

Gems omniauth-facebook >= 0 1.6.0

omniauth-facebook

Facebook OAuth2 Strategy for OmniAuth

This dependency is up-to-date. Congrats and keep going!

Gems omniauth-github >= 0 1.1.2

omniauth-github

Official OmniAuth strategy for GitHub.

This dependency is up-to-date. Congrats and keep going!

Gems omniauth-google-oauth2 >= 0 0.2.3

omniauth-google-oauth2

A Google OAuth2 strategy for OmniAuth 1.x

This dependency is up-to-date. Congrats and keep going!

Gems omniauth-twitter >= 0 1.0.1

omniauth-twitter

OmniAuth strategy for Twitter

This dependency is up-to-date. Congrats and keep going!

Gems spree_core ~> 2.3.0.beta 2.2.1

spree_core

The bare bones necessary for Spree.

This dependency is not matching latest version. Please consider upgrading.

Package Locked Requirement Latest Status Changelog
Gems capybara ~> 2.2.1 2.2.1

capybara

Capybara is an integration testing tool for rack based web applications. It simulates how a user would interact with a website

This dependency is up-to-date. Congrats and keep going!

Gems coffee-rails ~> 4.0.0 4.0.1

coffee-rails

CoffeeScript adapter for the Rails asset pipeline.

This dependency is up-to-date. Congrats and keep going!

Gems database_cleaner = 1.2.0 1.2.0

database_cleaner

Strategies for cleaning databases. Can be used to ensure a clean state for testing.

This dependency is up-to-date. Congrats and keep going!

Gems factory_girl ~> 4.4 4.4.0

factory_girl

factory_girl provides a framework and DSL for defining and using factories - less error-prone, more explicit, and all-around easier to work with than fixtures.

This dependency is up-to-date. Congrats and keep going!

Gems ffaker >= 0 1.24.0

ffaker

Faster Faker, generates dummy data.

This dependency is up-to-date. Congrats and keep going!

Gems guard-rspec >= 0 4.2.8

guard-rspec

Guard::RSpec automatically run your specs (much like autotest).

This dependency is up-to-date. Congrats and keep going!

Gems launchy >= 0 2.4.2

launchy

Launchy is helper class for launching cross-platform applications in a fire and forget manner. There are application concepts (browser, email client, etc) that are common across all platforms, and they may be launched differently on each platform. Launchy is here to make a common approach to launching external application from within ruby programs.

This dependency is up-to-date. Congrats and keep going!

Gems poltergeist ~> 1.5.0 1.5.0

poltergeist

Poltergeist is a driver for Capybara that allows you to run your tests on a headless WebKit browser, provided by PhantomJS.

This dependency is up-to-date. Congrats and keep going!

Gems pry-rails >= 0 0.3.2

pry-rails

Use Pry as your rails console

This dependency is up-to-date. Congrats and keep going!

Gems rspec-rails ~> 2.14 2.14.2

rspec-rails

RSpec for Rails

This dependency is up-to-date. Congrats and keep going!

Gems sass-rails ~> 4.0.0 4.0.3

sass-rails

Sass adapter for the Rails asset pipeline.

This dependency is up-to-date. Congrats and keep going!

Gems selenium-webdriver >= 0 2.41.0

selenium-webdriver

WebDriver is a tool for writing automated tests of websites. It aims to mimic the behaviour of a real user, and as such interacts with the HTML of the application.

This dependency is up-to-date. Congrats and keep going!

Gems simplecov ~> 0.7.1 0.8.2

simplecov

Code coverage for Ruby 1.9+ with a powerful configuration library and automatic merging of coverage across test suites

This dependency is not matching latest version. Please consider upgrading.

Gems sqlite3 ~> 1.3.8 1.3.9

sqlite3

This module allows Ruby programs to interface with the SQLite3 database engine (http://www.sqlite.org). You must have the SQLite engine installed in order to build this module. Note that this module is only compatible with SQLite 3.6.16 or newer.

This dependency is up-to-date. Congrats and keep going!