espower

13 17 0

Power Assert feature instrumentor based on The ESTree Spec (ECMAScript AST spec)

Dependencies

Package Locked Requirement Latest Status Changelog
Npms deep-equal ^1.0.0 1.0.1

deep-equal

node's assert.deepEqual algorithm

This dependency is up-to-date. Congrats and keep going!

Npms escallmatch ^1.4.0 1.5.0

escallmatch

ECMAScript CallExpression matcher made from function/method signature

This dependency is up-to-date. Congrats and keep going!

Npms escodegen ^1.6.1 1.8.1

escodegen

ECMAScript code generator

This dependency is up-to-date. Congrats and keep going!

Npms espurify ^1.2.0 1.6.0

espurify

Clone new AST without extra properties

This dependency is up-to-date. Congrats and keep going!

Npms estraverse ^4.1.0 4.2.0

estraverse

ECMAScript JS AST traversal functions

This dependency is up-to-date. Congrats and keep going!

Npms isarray ^0.0.1 2.0.0

isarray

Array#isArray for older browsers

This dependency is not matching latest version. Please consider upgrading.

Npms source-map ^0.4.2 0.5.6

source-map

Generates and consumes source maps

This dependency is not matching latest version. Please consider upgrading.

Npms type-name ^1.0.1 2.0.2

type-name

Just a reasonable typeof

This dependency is not matching latest version. Please consider upgrading.

Npms xtend ^4.0.0 4.0.1

xtend

extend like a boss

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Npms acorn ^1.0.3 4.0.3

acorn

ECMAScript parser

This dependency is not matching latest version. Please consider upgrading.

Npms blanket ^1.1.6 1.2.3

blanket

seamless js code coverage

This dependency is up-to-date. Congrats and keep going!

Npms browserify ^10.1.3 13.1.0

browserify

browser-side require() the node way

This dependency is not matching latest version. Please consider upgrading.

Npms del ^1.1.1 2.2.2

del

Delete files and folders

This dependency is not matching latest version. Please consider upgrading.

Bower escodegen 1.4.1 1.8.0

This dependency is not matching latest version. Please consider upgrading.

Bower estraverse ~1.9.0 4.2.0

This dependency is not matching latest version. Please consider upgrading.

Npms gulp ^3.8.11 3.9.1

gulp

The streaming build system

This dependency is up-to-date. Congrats and keep going!

Npms gulp-derequire ^2.1.0 2.1.0

gulp-derequire

A Gulp plugin to apply derequire to target Buffer/Stream

This dependency is up-to-date. Congrats and keep going!

Npms gulp-dereserve ^0.2.0 0.2.1

gulp-dereserve

gulp plugin to replace ES3 reserved keyword indentifiers

This dependency is up-to-date. Congrats and keep going!

Npms gulp-jshint ^1.10.0 2.0.1

gulp-jshint

JSHint plugin for gulp

This dependency is not matching latest version. Please consider upgrading.

Npms gulp-mocha ^2.0.1 3.0.1

gulp-mocha

Run Mocha tests

This dependency is not matching latest version. Please consider upgrading.

Npms gulp-mocha-phantomjs ^0.6.1 0.12.0

gulp-mocha-phantomjs

run client-side Mocha tests with PhantomJS

This dependency is not matching latest version. Please consider upgrading.

Npms gulp-util ^3.0.4 3.0.7

gulp-util

Utility functions for gulp plugins

This dependency is up-to-date. Congrats and keep going!

Npms gulp-webserver ^0.9.1 0.9.1

gulp-webserver

Gulp plugin to run a local webserver with LiveReload

This dependency is up-to-date. Congrats and keep going!

Npms jshint-stylish ^1.0.2 2.2.1

jshint-stylish

Stylish reporter for JSHint

This dependency is not matching latest version. Please consider upgrading.

Bower mocha ~2.2.4 2.5.3

This dependency is not matching latest version. Please consider upgrading.

Npms mocha ^2.2.4 3.0.2

mocha

simple, flexible, fun test framework

This dependency is not matching latest version. Please consider upgrading.

Npms mocha-lcov-reporter ^0.0.2 1.2.0

mocha-lcov-reporter

LCOV reporter for Mocha

This dependency is not matching latest version. Please consider upgrading.

Bower requirejs ~2.1.17 2.2.0

This dependency is not matching latest version. Please consider upgrading.

Npms through2 ^1.1.1 2.0.1

through2

A tiny wrapper around Node streams2 Transform to avoid explicit subclassing noise

This dependency is not matching latest version. Please consider upgrading.

Npms vinyl-source-stream ^1.1.0 1.1.0

vinyl-source-stream

Use conventional text streams at the start of your gulp or vinyl pipelines

This dependency is up-to-date. Congrats and keep going!