F1e3ab214a976a39cfd713bc93deb10f?s=64 visionmedia

express

20 12 0

Sinatra inspired web development framework for node.js -- insanely fast, flexible, and simple

Dependencies

Package Locked Requirement Latest Status Changelog
Npms accepts 1.0.1 1.0.1

accepts

Higher-level content negotiation

This dependency is up-to-date. Congrats and keep going!

Npms buffer-crc32 0.2.1 0.2.1

buffer-crc32

A pure javascript CRC32 algorithm that plays nice with binary data

This dependency is up-to-date. Congrats and keep going!

Npms cookie 0.1.1 0.1.2

cookie

cookie parsing and serialization

This dependency is not matching latest version. Please consider upgrading.

Npms cookie-signature 1.0.3 1.0.3

cookie-signature

Sign and unsign cookies

This dependency is up-to-date. Congrats and keep going!

Npms debug >= 0.7.3 < 1 0.8.0

debug

small debugging utility

This dependency is up-to-date. Congrats and keep going!

Npms escape-html 1.0.1 1.0.1

escape-html

Escape HTML entities

This dependency is up-to-date. Congrats and keep going!

Npms fresh 0.2.2 0.2.2

fresh

HTTP response freshness testing

This dependency is up-to-date. Congrats and keep going!

Npms merge-descriptors 0.0.2 0.0.2

merge-descriptors

Merge objects using descriptors

This dependency is up-to-date. Congrats and keep going!

Npms methods 0.1.0 0.1.0

methods

HTTP methods that node supports

This dependency is up-to-date. Congrats and keep going!

Npms parseurl 1.0.1 1.0.1

parseurl

parse a url with memoization

This dependency is up-to-date. Congrats and keep going!

Npms path-to-regexp 0.1.2 0.1.2

path-to-regexp

Express style path to RegExp utility

This dependency is up-to-date. Congrats and keep going!

Npms qs 0.6.6 0.6.6

qs

querystring parser

This dependency is up-to-date. Congrats and keep going!

Npms range-parser 1.0.0 1.0.0

range-parser

Range header field string parser

This dependency is up-to-date. Congrats and keep going!

Npms send 0.2.0 0.2.0

send

Better streaming static file server with Range and conditional-GET support

This dependency is up-to-date. Congrats and keep going!

Npms serve-static 1.0.4 1.0.4

serve-static

Serve static files

This dependency is up-to-date. Congrats and keep going!

Npms type-is 1.1.0 1.1.0

type-is

Infer the content type if a request

This dependency is up-to-date. Congrats and keep going!

Npms utils-merge 1.0.0 1.0.0

utils-merge

merge() utility function

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Npms body-parser 1.0.0 1.0.2

body-parser

Connect's body parsing middleware

This dependency is not matching latest version. Please consider upgrading.

Npms connect-redis ~1.4.5 1.5.0

connect-redis

Redis session store for Connect

This dependency is not matching latest version. Please consider upgrading.

Npms cookie-parser 1.0.1 1.0.1

cookie-parser

cookie parsing with signatures

This dependency is up-to-date. Congrats and keep going!

Npms ejs ~0.8.4 1.0.0

ejs

Embedded JavaScript templates

This dependency is not matching latest version. Please consider upgrading.

Npms express-session 1.0.1 1.0.2

express-session

Setup session store with the given `options`.

This dependency is not matching latest version. Please consider upgrading.

Npms hjs ~0.0.6 0.0.6

hjs

Hogan.js NPM package for express 3.x

This dependency is up-to-date. Congrats and keep going!

Npms jade ~0.30.0 1.3.1

jade

Jade template engine

This dependency is not matching latest version. Please consider upgrading.

Npms marked 0.2.10 0.3.2

marked

A markdown parser built for speed

This dependency is not matching latest version. Please consider upgrading.

Npms mocha ~1.15.1 1.18.2

mocha

simple, flexible, fun test framework

This dependency is not matching latest version. Please consider upgrading.

Npms morgan 1.0.0 1.0.0

morgan

connect's logger for node.js

This dependency is up-to-date. Congrats and keep going!

Npms should ~2.1.1 3.3.1

should

test framework agnostic BDD-style assertions

This dependency is not matching latest version. Please consider upgrading.

Npms static-favicon 1.0.0 1.0.2

static-favicon

favicon serving middleware with caching

This dependency is not matching latest version. Please consider upgrading.

Npms stylus ~0.40.0 0.43.1

stylus

Robust, expressive, and feature-rich CSS superset

This dependency is not matching latest version. Please consider upgrading.

Npms supertest ~0.8.1 0.10.0

supertest

Super-agent driven library for testing HTTP servers

This dependency is not matching latest version. Please consider upgrading.

Npms vhost 1.0.0 1.0.0

vhost

virtual domain hosting

This dependency is up-to-date. Congrats and keep going!