vodolaz095 vodolaz095

hunt

19 43 1

High level nodejs framework build on top of expressjs, mongoose, sequilize, socketio and passportjs

You have 1 open security alert

Dependencies

Package Locked Requirement Latest Status Changelog
Bower angular ~1.3.15 1.6.4

This dependency is not matching latest version. Please consider upgrading.

Bower angular-route ~1.3.15 1.6.4

This dependency is not matching latest version. Please consider upgrading.

Bower async ~1.5.0 2.4.1

This dependency is not matching latest version. Please consider upgrading.

Npms async 1.5.0 2.4.1

async

Higher-order functions and common patterns for asynchronous code

This dependency is not matching latest version. Please consider upgrading.

Npms body-parser 1.14.1 1.17.2

body-parser

Node.js body parsing middleware

This dependency is not matching latest version. Please consider upgrading.

Bower bootstrap ~3.1.1 3.3.7

This dependency is not matching latest version. Please consider upgrading.

Npms compression 1.6.0 1.6.2

compression

Node.js compression middleware

This dependency is not matching latest version. Please consider upgrading.

Npms connect-flash 0.1.1 0.1.1

connect-flash

Flash message middleware for Connect.

This dependency is up-to-date. Congrats and keep going!

Npms connect-multiparty 2.0.0 2.0.0

connect-multiparty

multipart parsing middleware for connect using multiparty

This dependency is up-to-date. Congrats and keep going!

Npms connect-redis 3.0.1 3.3.0

connect-redis

Redis session store for Connect

This dependency is not matching latest version. Please consider upgrading.

Npms cookie-parser 1.4.0 1.4.3

cookie-parser

cookie parsing with signatures

This dependency is not matching latest version. Please consider upgrading.

Npms csurf 1.8.3 1.9.0

csurf

CSRF token middleware

This dependency is not matching latest version. Please consider upgrading.

Npms errorhandler 1.4.2 1.5.0

errorhandler

Development-only error handler middleware

This dependency is not matching latest version. Please consider upgrading.

Npms eventemitter2 0.4.14 4.1.0

eventemitter2

A Node.js event emitter implementation with namespaces, wildcards, TTL and browser support.

This dependency is not matching latest version. Please consider upgrading.

Npms express 4.13.3 4.15.3

express

Fast, unopinionated, minimalist web framework

This dependency is not matching latest version. Please consider upgrading.

Npms express-handlebars 2.0.1 3.0.0

express-handlebars

A Handlebars view engine for Express which doesn't suck.

This dependency is not matching latest version. Please consider upgrading.

Npms express-session 1.12.1 1.15.3

express-session

Simple session middleware for Express

This dependency is not matching latest version. Please consider upgrading.

Npms glob ^5.0.15 7.1.2

glob

a little globber

This dependency is not matching latest version. Please consider upgrading.

Npms hogan-express 0.5.2 0.5.2

hogan-express

Mustache template engine for express 3.x. Support partials and layout

This dependency is up-to-date. Congrats and keep going!

Npms jade 1.11.0 1.11.0

jade

A clean, whitespace-sensitive template language for writing HTML

This dependency is up-to-date. Congrats and keep going!

Bower jquery ~2.1.3 3.2.1

This dependency is not matching latest version. Please consider upgrading.

Npms kerberos 0.0.17 0.0.23

kerberos

Kerberos library for Node.js

This dependency is not matching latest version. Please consider upgrading.

Npms method-override 2.3.5 2.3.9

method-override

Override HTTP verbs

This dependency is not matching latest version. Please consider upgrading.

Npms mongoose 4.2.6 4.10.2

mongoose

Mongoose MongoDB ODM

This dependency is not matching latest version. Please consider upgrading.

Npms nodemailer 1.10.0 4.0.1

nodemailer

Easy as cake e-mail sending from your Node.js applications

This dependency is not matching latest version. Please consider upgrading.

Npms nodemailer-html-to-text 1.0.2 2.1.0

nodemailer-html-to-text

Generate text content from html for Nodemailer e-mails

This dependency is not matching latest version. Please consider upgrading.

Npms passport 0.3.0 0.3.2

passport

Simple, unobtrusive authentication for Node.js.

This dependency is not matching latest version. Please consider upgrading.

Npms passport-facebook 2.0.0 2.1.1

passport-facebook

Facebook authentication strategy for Passport.

This dependency is not matching latest version. Please consider upgrading.

Npms passport-github 1.0.0 1.1.0

passport-github

GitHub authentication strategy for Passport.

This dependency is not matching latest version. Please consider upgrading.

Npms passport-google-oauth 0.2.0 1.0.0

passport-google-oauth

Google (OAuth) authentication strategies for Passport.

This dependency is not matching latest version. Please consider upgrading.

Npms passport-steam 0.1.6 1.0.8

passport-steam

Steam (OpenID) authentication strategy for Passport.

This dependency is not matching latest version. Please consider upgrading.

Npms passport-twitter 1.0.3 1.0.4

passport-twitter

Twitter authentication strategy for Passport.

This dependency is not matching latest version. Please consider upgrading.

Npms passport-vkontakte 0.4.0 0.3.2

passport-vkontakte

VK.com authentication strategy for Passport.

This dependency is up-to-date. Congrats and keep going!

Npms q 1.4.1 1.5.0

q

A library for promises (CommonJS/Promises/A,B,D)

This dependency is not matching latest version. Please consider upgrading.

Npms rai 0.1.12 0.1.12

rai

Request-Answer-Interface for generating text based command servers (SMTP, POP etc)

This dependency is up-to-date. Congrats and keep going!

Npms redis 1.0.0 2.7.1

redis

Redis client library

This dependency is not matching latest version. Please consider upgrading.

Npms request 2.65.0 2.81.0

request

Simplified HTTP request client.

Security alert:

Npms response-time 2.3.1 2.3.2

response-time

Response time for Node.js servers

This dependency is not matching latest version. Please consider upgrading.

Npms serve-favicon 2.3.0 2.4.3

serve-favicon

favicon serving middleware with caching

This dependency is not matching latest version. Please consider upgrading.

Npms socket.io 1.3.7 2.0.1

socket.io

Real-time apps made cross-browser & easy with a WebSocket-like API

This dependency is not matching latest version. Please consider upgrading.

Npms socket.io-redis 0.1.4 5.0.1

socket.io-redis

[![Build Status](https://travis-ci.org/socketio/socket.io-redis.svg?branch=master)](https://travis-ci.org/socketio/socket.io-redis) [![NPM version](https://badge.fury.io/js/socket.io-redis.svg)](http://badge.fury.io/js/socket.io-redis)

This dependency is not matching latest version. Please consider upgrading.

Bower socket.io.client ~1.3.5 1.3.5

This dependency is up-to-date. Congrats and keep going!

Npms swig 1.4.2 1.4.2

swig

A simple, powerful, and extendable templating engine for node.js and browsers, similar to Django, Jinja2, and Twig.

This dependency is up-to-date. Congrats and keep going!

Npms validator 4.2.1 7.0.0

validator

String validation and sanitization

This dependency is not matching latest version. Please consider upgrading.

Npms winston ^2.1.1 2.3.1

winston

A multi-transport async logging library for Node.js

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Npms bower 1.5.3 1.8.0

bower

The browser package manager

This dependency is not matching latest version. Please consider upgrading.

Npms del >=2.0.0 2.2.2

del

Delete files and folders

This dependency is up-to-date. Congrats and keep going!

Npms gulp >=3.8.11 3.9.1

gulp

The streaming build system

This dependency is up-to-date. Congrats and keep going!

Npms gulp-bower >=0.0.10 0.0.13

gulp-bower

Install Bower packages.

This dependency is up-to-date. Congrats and keep going!

Npms gulp-concat >=2.6.0 2.6.1

gulp-concat

Concatenates files

This dependency is up-to-date. Congrats and keep going!

Npms gulp-filter >=3.0.1 5.0.0

gulp-filter

Filter files in a Vinyl stream

This dependency is up-to-date. Congrats and keep going!

Npms gulp-minify-css >=1.2.1 1.2.4

gulp-minify-css

Minify css with clean-css.

This dependency is up-to-date. Congrats and keep going!

Npms gulp-order ^1.1.1 1.1.1

gulp-order

The gulp plugin `gulp-order` allows you to reorder a stream of files using the same syntax as of `gulp.src`.

This dependency is up-to-date. Congrats and keep going!

Npms gulp-rename >=1.2.2 1.2.2

gulp-rename

Rename files

This dependency is up-to-date. Congrats and keep going!

Npms gulp-uglify >=1.4.0 3.0.0

gulp-uglify

Minify files with UglifyJS.

This dependency is up-to-date. Congrats and keep going!

Npms istanbul 0.4.0 0.4.5

istanbul

Yet another JS code coverage tool that computes statement, line, function and branch coverage with module loader hooks to transparently add coverage when running tests. Supports all JS coverage use cases including unit tests, server side functional tests

This dependency is not matching latest version. Please consider upgrading.

Npms jsdoc 3.3.3 3.4.3

jsdoc

An API documentation generator for JavaScript.

This dependency is not matching latest version. Please consider upgrading.

Npms jshint 2.8.0 2.9.4

jshint

Static analysis tool for JavaScript

This dependency is not matching latest version. Please consider upgrading.

Npms jslint 0.9.3 0.10.3

jslint

The JavaScript Code Quality Tool

This dependency is not matching latest version. Please consider upgrading.

Npms main-bower-files >=2.9.0 2.13.1

main-bower-files

Get main files from your installed bower packages.

This dependency is up-to-date. Congrats and keep going!

Npms mocha 2.3.3 3.4.2

mocha

simple, flexible, fun test framework

This dependency is not matching latest version. Please consider upgrading.

Npms should 7.1.0 11.2.1

should

test framework agnostic BDD-style assertions

This dependency is not matching latest version. Please consider upgrading.

Npms socket.io-client 1.3.7 2.0.1

socket.io-client

[![Build Status](https://secure.travis-ci.org/socketio/socket.io-client.svg?branch=master)](http://travis-ci.org/socketio/socket.io-client) [![Dependency Status](https://david-dm.org/socketio/socket.io-client.svg)](https://david-dm.org/socketio/socket.io-

This dependency is not matching latest version. Please consider upgrading.